Great Phone Offers With All You Can Eat Data |

My3 Questions Board for Bill Pay

3 Community Manager

My3 Questions Board for Bill Pay

Hello Community,


Here's the place to post your questions and share your solutions for My3 with other members. 

Are you new to the Community? Why don't you have a look at our blog on how to get started


Remember that your Mods are here to help you and sometimes you'll need to send us a PM with your details ( full name, number, address and date of birth) Meet the Mods  






@GBN thanks for that, appreciate it. Some of our plans have 14GB data roaming allowance included. while it's called an add-on, you're not charged for it 👍


@Thminator and @GBN , I'd like to find out why you got this text as it's not a usual thing. Can you both send me a PM with your account details and your numbers? With these, I'll be able to investigate 😊 



I just went through the upgrade process of My3 and now webtext is gone. After the upgrade completed, I kogged out and in again, clicked on My3 -> Quicklinks -> Send a webtext and was aked to enter a security code that was send to my phone. But instead of being forwarded to webtext I am redirected to "". I tried the usual like clearing cache, cookies etc. Even using different browsers doesn't work.




The week before last, I attempted to register for MyAccount, but in all the confusion, I entered the wrong email address. Therefore, I have not obviously received a link to complete the registration.


I attempted over the phone (could not get through) and on chat to ffix this, and on chat I was told it would take 7 days. It is now 7 days. Interestingly, I was able to register here to post this private message with my correct address, but I guess that is seperate to MyAccount. Could you have a look and help me solve this. I am anxious to sort this ASAP as I overused my data last month and I want to see what changes I can make to stop this happening again, given I am doing more video calls now.


Please help



@Maggie47_Kil Good morning 👋 @Three_Laur has replied to your PM as we need more account details from you to check this out.

On the other hand, have you considered changing your plan to include more data?  @Three_Laur will look into this for you too 👌 





I recently received a text saying that I had reached "90% of [your] defined credit limit 35". I had recently purchased a sim-only Unlimited Broadband Plan, so had not expected to be running into cap issues. I have attempted to register on My3 so that I can view my plan/cap etc. but when I click the "verify email button" on the Confirm Registration email, I am taken to a page that says "No verification code data found" (or sometimes a message about an invalid user). I can log in using the email/password combination that I created during set-up, but I am taken to an error page that says "


What you are looking could not be found.
Error Code: 400"
I am unsure as to how to proceed, but I would greatly appreciate any help with 1) accessing my account and 2) clarifying the credit limit issue.

@Cengler To help you I'll need to access your account from my side. Will you send me a PM with your name, number, address, and date of birth? 

Hi. The same thing is happening to me. After clicking on the email to verify my account, I am given the message of , "No verification code data found." So basically I cannot access my My3 account and when I try and log in I am told, "Incorrect Username or Password. Account will be locked after 5 incorrect attempts"


Please can you help me to fix this please. Thank you.

@FindingAnswers Hi there, when you are logging in are you using your number or email address? Have you tried clicking on the forgotten password option? 

Hi Deborah,


The reason why I can't log in is because my account has not been verified. The reason why it hasn't been verified is because of what happens when I click on the link to verify my account from the email that was sent to me. So without being able to verify my account, I will not be able to log into my My3 account. So I need help to get past that message that I receive when I try to verify my account.


Thank you and kind regards,


OK, try logging in using the email address that you used when you registered.
I noticed that the email address is case sensitive, so try that