Great Phone Offers With All You Can Eat Data | Three.ie

Issue with 5G

Padair
Explorer

Issue with 5G

Hi there,

 

I am looking for some help. I have bought a new 5G router and I am getting a full 5G signal on the router but I am not getting 5G speeds.

 

I have added the 5 euro top up to my account and bought the 5G service but nothing. I have checked the eircode checker for 5g and it says I am in coverage.

 

Any help would be appreciated. 

 

P.

16 REPLIES 16
Three_Deborah
3 Community Manager

@Padair Good morning, 5G is being rolled out at the moment and is available in some locations across the country and available on some phones and phone plans. It's not yet built into our mobile broadband plans but it will be soon. Can you tell me the router type you have and the name of your plan? It's possible that the plan is for a phone 

🤔

Hey Deborah,

I have the huawei-5g-cpe-pro-2

I have a prepay sim with 5g service turned on. I have checked the 5g checker and I am in the 5g area. If you would like the eircode let me know
Three_Deborah
3 Community Manager

@Padair  thanks for that. I'm not familiar with that router, the one we currently supply is a B535, however it's not 5G enabled. The Prepay plan you mentioned is for a phone. Can you try that SIM in a 5G enabled phone please and let us know how it goes? For the moment, 5G isn't supported on broadband and we're eagerly awaiting it's rollout 💪

 

Hi there,
I have tried this sim in a 5g enabled phone and i do not see a 5g option in the network settings. When I tried another sim that is not thoree I get a 5g option

@Padair Hi there, I'm happy to check this out for you, what's the make and model of the phone you're using?

 

 

I am using a oneplus 8t
Thanks

@Padair I've linked in with the relevant team for you and they're currently working with OnePlus to enable their 5G handsets over the coming months so watch this space 👌

 

 

Hi @Padair,

 

I can't get a date from Three about when a supported 5g router will be available, so I was just about to buy the same router as you (not cheap!) to do the same thing, and I noticed this thread.

 

Just wondering if you've made any progress with it since your last post?

 

Thanks!

No progress, I sent back the router.
I also tried to use 5g on oneplus phone and that didn't work either. Best
to wait until the network is more mature imo.