Great Phone Offers With All You Can Eat Data | Three.ie

Online order questions

3 Community Manager

Online order questions

Hi all, with our 3Stores temporarily closed, there are more online orders now than ever before. Did you know we have a handy 3MadeEasy blog to help you with this? Have a look here πŸ‘‰ click here . If you have any questions that aren't answered there, why not search your Community and/or reply below. Other members here will share their advise and experience πŸ’ͺ Remember, for something related to your specific account, please PM one of your Community Mods πŸ˜Š

 

 

63 REPLIES 63
Scout

Hi there, 

I have been with three for many years and was eligible for an upgrade in 2019 which I have not availed of yet. 

 

I am interested in an iphone11 however I have noticed that for me to upgrade to this phone and stay on my current plan (classic flex max), the device cost is 399. However, if I was a new customer and was to choose the same plan, the device cost is 199. 

 

Why is the device cost 200 euro dearer for an upgrade for a customer who has been with you for many years than for a new customer?

 

 

@annaw85 Hi there, from time to time we run different types of promotions for different account types. For existing customers, offers are usually account related. One of the Mods here will be able to see which discounts applied to you. All you need to do is send your full name, number, address and date of birth to us. Remember to do this via PM πŸ‘

Scout

 
Scout

Hi I’m waiting on a confirmation email placed an order today thanks

@Nicola1 Hi there, have you received this? Did you order a new phone or SIM only number? 

I was able to get a better price using the chat portal recently but wasn’t able to avail due to cash restraints ...I tried to get same deal now on iPhone 11 Pro but seems the offer is gone ..do three run offers for customers from time to time ?

Try the chat portal again, as the offer may still be available that way

Unfortunately not ...thanks anyway πŸ‘
Scout

Hi, I’ve placed an order online and received a confirmation email but when I use the order number to try and track, the An Post website is not recognising the item number. I’ve tried leaving out the A as suggested but still not recognising it.